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Copyright Notice
© Copyright 2018 by Melco

ALL RIGHTS RESERVED No part of this publication may be reproduced, stored in a retrieval system, or 
transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise) 
without prior written approval of Melco. Melco reserves the right to revise this publication and to make 
changes in it at any time without obligation of Melco to notify any person or organization of such revi-
sions or changes.

All precautions have been taken to avoid errors or misrepresentations of facts, equipment, or prod-
ucts. However, Melco does not assume any liability to any party for loss or damage caused by errors or 
omissions.

Melco Technology is protected by - but not limited to - the following patents:

•	 Pat. US 6,445,970 B1

•	 Pat. US 6,823,807

•	 Pat. CH 693569 A5

•	 Pat. US 6,736,077 B2

•	 Pat. US 6,732,668 B2

•	 Pat. US 6,871,605

•	 Pat. US 6,983,192 B2

•	 Pat. US 7,308,333 B2

•	 Pat. US 7,513,202

•	 Pat. US 8,851,001 B2

•	 Pat. US 9,702,070

•	 Other patents pending
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DesignShop Product Levels
The following DesignShop product levels are available.  This table also provides a brief overview of some 
of basic features available in each level. The feature availability is described in more detail throughout the 
manual.

Feature DesignShop 
Lite

DesignShop 
(Standard)

DesignShop 
Pro

DesignShop 
Pro+

Lettering 160+ 
alphabets

160+ 
alphabets

160+ 
alphabets

160+ 
alphabets

Scaling, Mirroring, & Rotating Designs • • • •

Editing of Basic Properties (Density, Underlays) • • • •

Editing Wireframe Shapes • • • •

Editing Expanded Points • • •

Digitizing Wireframe Shapes • • •

Alignment Tools • • •

Raster Graphic File Support • • •

Vector Graphic File Support •

Raster Graphic to Embroidery Conversion • •

Vector Graphic to Embroidery Conversion •

Stock Pattern & Decorative Fills • • •

User Created Pattern & Decorative Fills •

Distortion Fill Effects • •

Random Stitch Lengths • • •

Photo Fill •

Cross Stitch •
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View Bar
The view bar contains the zoom tools as well as view settings and editing modes.

Object Bar
The object bar contains  various tools for centering a design, updated trims and ties, as well as graphic to 
embroidery assistance tools.

Property Bar

The property bar shows the most common properties of any tool or element that is selected. If multi-
ple elements are selected, only those properties that are shared between the selected elements will be 
displayed.

Input Toolbar
The input toolbar contains the majority of the tools used for digitizing, editing, selecting, and sequencing 
a design.

The tools on this bar will change depending on what tool or element is selected.
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View Window
The View Window acts as the main workspace for digitizing and editing. A preview of the project is 
displayed.

When a project is open, right-clicking in a blank area of the view window will bring up a selection con-
text menu. This menu mostly contains input tools.

If multiple projects are open, each project will have a view window. Typically these are layered, but they 
can be tiled or rearranged. The Window menu provides the option for tiling or cascading these windows.

Changing the Workspace Size
The size of the workspace in the view window can be altered by the 
following steps:

1.	 Select the project in the project view.

2.	 Right-click on the selected project and choose "Project" from 
the context menu.

3.	 Change the workspace area dimensions.

4.	 Click OK.
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Project View
Typically found on the right side of the screen, the project view contains non-visual information about the 
design. The sew sequence, color information, and element types are all visible here.

•• If the project view is closed, go to View>Project Views and select "Project View 1" to retrieve it.

The size of the elements in the project view may be adjusted by right-clicking and selecting Tree Image 
Size from the context menu.

The background color of the project view may be altered by right-clicking and selecting Tree Background 
Color from the context menu.
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Project View
Typically found on the right side of the screen, the project view contains non-visual information about the 
design. Within the project view are three tabs: the project tab, the stitches tab, and the navigator tab. 
These tabs are accessed from the bottom of the project view.

The project view can be detached from the side of the screen and moved to another monitor or else-
where on screen. To do this click and drag the title bar of the window (no words exist in the project view 
title bar). Once detached, the project view can be moved to the desired area. Double-clicking on the title 
bar will return the project view to the original docked position.

•• If the project view is closed, go to View>Project Views and select "Project View 1" to retrieve it.

Project Tab
The project tab contains a list of elements found in the design. The order in which these elements are 
displayed determine the order in which they sew.

Elements and range of elements may also be selected from the project tab. By selecting elements in the 
project view, you can make adjustments to the properties of large or small sections of a project.

The project tab functions in tier levels. If you select at a level, you can affect all subsequent levels and 
elements. These levels may be collapsed or expanded by clicking the expand or collapse button to the left 
of the individual levels.

Expand All and Collapse All buttons are available at the top of the project tab.

•• To navigate through the element list of the project tab, you can use the scroll wheel of a 
mouse, or the arrow keys, the Home, End, Page Up, and Page Down buttons on the keyboard.
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Lock Elements
Sections of a project may be locked to prevent accidental selecting or mov-
ing. Locked elements will not move or be selected from the view window. 
They can still be selected and properties altered from the project view.

To the left of each level and element, two small squares exist. The right 
square is the lock box. To lock or unlock elements, click in the lock box 
to the left of the level or element that you wish to lock. If an padlock 
is in the box, the level/element will be locked. If the box is empty, the 
level/element will be unlocked.

Elements can also be locked or unlocked by selecting elements and choosing Object>(Un)Lock Element.

If you mouse over a selected locked element in the view window, a locked cursor will appear. This is just 
to indicate that the selected element is locked and cannot be moved.
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Right-Click Context Menu
Right-clicking within the project tab will bring up a context menu in which you can access several func-
tions. Most of these functions are also available from menus and toolbars as well.

Merge Color Blocks
To the right of each color block is the merge icon. Clicking on this will 
merge the color block into the one above it. This will eliminate the col-
or change command sent to the machine and make the elements from 
both original blocks the same color.
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Navigator Tab
The third tab of the project view displays the design and view window in 
relation to the workspace. The red box represents the view window borders.

Moving the View Window

By clicking and dragging the red box, you can change the position of the 
view window in relation to the design.

Zoom Within the Navigator

To change the zoom level while in the navigator tab, hold CTRL and click 
and drag a box withing the navigator tab. When you release the mouse 
button, a new size of box will be displayed, and the view window will match 
the contents of that box.
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Navigating the Workspace
There are many ways to customize your workspace and view your designs the way that you prefer.

Showing or hiding guides, hoop outlines, or certain types of stitches can be helpful when editing or pre-
paring a design for embroidery. The View Toolbar will be the toolbar most used in adjust what appears in 
the view window of the softwares. If it is not visible, go to View>Toolbars> and ensure there is a check-
mark by "view".

Measurement Units
You have the option of changing the measurement units in the software for multiple properties.

To access this, go to Tools>Options and select the Measurement Units Tab.

From the measurement units tab, you can select different measurement units for different properties. It is 
common for embroiderers and digitizers to have some properties as inches and others in points.

Point mm cm Inch French Inch 
(Pouce)

1 Point = 1 0.1 0.01 0.003937 0.0036941

1 mm = 10 1 0.1 0.03937 0.0369412

1 cm = 100 10 1 0.3937 0.3694126

1 Inch = 254 25.4 2.54 1 0.9380863

1 Pouce = 270.7 27.07 2.707 1.066 1
Table for Measurement Conversion

Ruler
The ruler tool can be used to measure anything 
in the view window and read the actual length. 
To use the ruler tool:

1.	 Select it from the toolbar.

2.	 Click and drag across the object to be measured in the view window.

3.	 The length will be displayed beside the ruler.
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Snap to Grid Mode
Snap to Grid can be useful when digitizing. The grid needs only to be spaced the way you would prefer 
it. It does not need to be visible to utilize Snap to Grid.

When Snap to Grid is enabled, the input points created while digitizing will "snap" to the closest grid 
intersection point.

•	 To enable Snap to Grid, go to View>Snap to Grid. A check mark will be displayed if it is enabled. 
Repeating the process will disable the feature.
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Selecting Wireframe Elements in the Project View
Single elements in the project view by clicking on the element (preview, number, or name). The select-
ed element will then be highlighted in the project view and displayed with a resize/edit box in the view 
window.

Selecting Multiple Wireframe Elements in the Project View
Multiple elements may be selected in the project view by the following 
methods.

•	 CTRL + Click - Select Non-Consecutive Elements - Click on a single 
element. Hold CTRL and click on any other elements that you would 
like to select. This will select only those elements clicked.

•	 Shift + Click - Select Consecutive Elements - Click on a single ele-
ment. Hold CTRL and click on another element. This will select these 
two elements and all elements in between.

•	 Select Same Type - Right-click on a selected element and choose Select>Select Same Type from 
the context menu. This will select all of that type of element within a project. This is also available 
under the Edit menu.

•	 Select Entire Design - Right-click on a selected element and choose Select>Select Entire Design 
from the context menu. This will select the entire design of which that element is a part. This is 
also available under the Edit menu.

•	 Select All - Right-click on a selected element and choose Select>Select All from the context menu. 
This will select the entire project. This is also available under the Edit menu.

Other Selection Methods
The following selection methods fall outside the view window and project view.

•	 Select Entire Project - Click on the Select Entire Project button on the input toolbar to select 
the entire project.

•	 Select Color - Right-click on an active color and choose Select Color to select every instance 
of that color in a project.

•	 Deselect All - Right-click on a selected element and choose Select>Deselect All from the context 
menu. This will deselect any selected elements. This is also available under the Edit menu.

Selecting Expanded Elements
Expanded elements may be selected using all of the same methods as the wireframe elements. The major 
difference is that expanded elements are usually only separated by a trim or color block. This means that 
you typically will be selecting larger sections of stitches.
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Copy
The Copy command will place a copy of the selected element(s) on the clipboard. Unlike the cut com-
mand, it will not remove the elements from the project.

From the clipboard, these element(s) may be pasted back into the project later.

•• If another element is placed on the clipboard, the new element will replace the original copy.

To use the copy command, use one of the following methods:

•	 Go to Edit>Copy.

•	 Click on the Copy icon on the main toolbar.

•	 Right-click on the selected element(s) and select Copy from the context menu.

•	 Use the keyboard shortcut of CTRL + C.

Paste
The Paste command will place a copy of the element(s) from the clipboard into the project. Unlike some 
graphics programs, the new element(s) will not be slightly shifted from the original. The exact positions 
of the input points or needle penetrations are maintained.

•• When pasting from the clipboard, the X/Y position is set, but you will need to consider where/
when in the sew sequence you would prefer the new element(s) to appear. The pasted ele-
ment(s) will be inserted into the project after whatever element is selected. If no element is 
selected, the pasted element will appear at the end of the project. This is most easily observed 
in the project tab.

To use the paste command, use one of the following methods:

•	 Go to Edit>Paste.

•	 Click on the Paste icon on the main toolbar.

•	 Right-click on a selected element and select Paste from the context menu.

•	 Use the keyboard shortcut of CTRL + V.

Cut, Copy, & Paste Between Programs
The cut, copy, and paste commands can occasionally be used between DesignShop and other programs 
with varying degrees of success. Some illustration programs can utilize the wireframe data as vector 
shapes while maintaining some stitch information in the background. This enables you to edit the shapes 
in one program and paste them back into DesignShop while keeping some stitch information.
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Align / Evenly Space Elements
Elements or grouped elements may be aligned with one another in the software. They may also be dis-
tributed evenly between the two farthest elements.

To align or space elements, use one of the following:

•	 Go to Object>Align>[Desired Action]

•	 Use the icons on the Align toolbar.

•	 Align Top - aligns the tops of the selected elements to the top-most edge of the top-most 
element. 

•	 Align Bottom - aligns the bottom edge of the selected elements to the bottom-most edge of 
the bottom-most element. 

•	 Align Left - aligns the left edge of the selected elements to the left-most edge of the left-most 
element. 

•	 Align Right - aligns the bottom edge of the selected elements to the bottom-most edge of the 
bottom-most element. 

•	 Vertically Center - aligns the center of the selected elements to the center horizontal axis of 
the resize/edit box. 

•	 Horizontally Center - aligns the center of the selected elements to the center vertical axis of 
the resize/edit box. 

•	 Space Evenly Vertically - distributes the heights of the selected elements evenly between the 
top edge of the top-most element and the bottom edge of the bottom-most element. 

•	 Space Evenly Horizontally - distributes the widths of the selected elements evenly between the 
left edge of the left-most element and the right edge of the right-most element. 

•• Align commands will only be available with two or more elements selected. Space evenly com-
mands will only be available when three or more elements are selected.
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Auto Kern
While the control of manually or on-screen (below) kerning is 
great, sometimes to speed production you need an automatic 
option. Auto Kern is a feature in the software that will exam-
ine the lettering for you and adjust the space to appear as a 
percentage of the height.

To use the auto kern feature:

1.	 Access the properties of the selected lettering element.

2.	 Select the "Spacing" sub menu below "Letters"

3.	 Check the Auto Kern check box to enable.

4.	 Adjust the percentage.

5.	 Click Apply to see the changes.

•• Auto Kern works well for a variety of typefaces, but 
not all. Be careful when working with connected 
scripts or any monogram alphabets. Auto kern adds 
typically undesired space to connected or precisely 
spaced alphabets.

Times New Roman - No Auto Kern

Shell Script - No Auto Kern

Times New Roman - Auto Kern at 10%

Shell Script - Auto Kern at 10%
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Word Spacing
Automatic word spacing is located in the same window as 
Auto Kern (above). This will ignore the programmed space 
assigned to the space bar key and utilize a percentage of the 
letter height. To use word spacing:

1.	 Access the properties of the selected lettering element.

2.	 Select the "Spacing" sub menu below "Letters"

3.	 Uncheck the "Use Default Spacing" check box to en-
able the use of the percentage.

4.	 Adjust the percentage.

5.	 Click Apply to see the changes in the view window.

Micro Block - Default Word Spacing

Micro Block - Word Spacing at 40%

On-Screen Kerning

If on-screen manipulation is more to your liking, you can kern lettering in the view window

To graphically kern lettering, use the following steps:

1.	 Select the lettering element in the view window by clicking on it.

2.	 Click and drag on the handle (X in the middle of the letter) of the letter you wish to move. The 
letter will move along the baseline.

•	 If more than one letter is to be moved together, click on the handle of one letter, then hold 
CTRL and click on the handle of the other desired letters. This will select multiple letters. 
Release the CTRL key.

•	 To move them, click within the resize/edit box (this time avoiding the handles) and drag. If 
you click on the handle of a single letter, the resize/edit box will reduce to the single letter and 
deselect all other currently selected letters.

3.	 Release the handle and examine your work.

On-screen Kerning 
Berfore

On-screen Kerning 
During

On-screen Kerning 
After

•• Hold the CTRL key while dragging a single letter to move it off of the baseline.
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Auto Borders (Lettering)
The automatic addition of borders to lettering elements is ac-
cessed through the Auto Borders sub window. To enable this 
feature, do the following:

1.	 Select a lettering element.

2.	 Access the properties of the element by right-clicking 
on the element and selecting properties or double-click 
on the element.

3.	 If the Letters category is collapsed on the left, expand 
it.

4.	 Select the Auto Borders sub-category.

5.	 Check the Enable Auto Border Check Box

6.	 Adjust the properties below.

7.	 Click Apply to see the changes.

Auto Border Properties
Below the enable check box, there are several properties to 
adjust. These will only be enabled if the feature has been enabled.

Stitch Type

From the stitch type drop-down, you can choose the follow types of stitches for your borders.

Satin - arguably the most common border type. Just make sure that your width is larger than the needle 
that you are sewing with and gives you enough room for bit a of pull from the letter underneath. Too 
thin, and the letter and border will not line up like they appear on screen.

•	 Walk Normal - Borders your lettering in a single line of stitches.

•	 Walk Bean - This choice will border your lettering in a line of triple stitches. Each stitch will go over 
the same spot three times before continuing to the next stitch.

•	 Appliqué - A level dependent choice, this will switch your lettering from normal embroidery into 
an appliqué element.

•	 Tackle - This will border your letters in a tackle-style stitch.

All properties for the stitch types are listed as sub-categories of the Auto-Borders.

•• Adjusting the pull offset of the lettering you intend to border by adding a couple of points will 
increase the likelihood that your letters and borders will align as they appear on screen. Using 
underlay under the lettering will also help. See both the Pull Comp and Underlay sections for 
more information on those features.
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Underlay

Underlay is a sub-category to Top Stitching and applies to 
multi stitch-line elements. It can be accessed from both the 
property bar and the properties window.

Underlay stitches are often used as foundation stitches for 
embroidery. Underlay is used to stabilize the material by at-
taching it to the backing. It can tack down material nap, and 
it can add loft by building up your stitches. 

Continuous Underlay (Lettering)
Lettering elements have the option to use continuous underly. 
This check box only appears for lettering elements. Using this 
feature will underlay an entire letterform before starting the 
top stitching. If this feature is disabled, each segment of the 
letter will underlay and sew the top stitching before moving to the next segment.

Continuous underlay can help keep the joints of smaller letters from gapping.

Auto-Underlay
Auto-underlay is a feature that bases the type of 
underlay on the average stitch line length of the ele-
ment. There are four size ranges and the properties 
for those ranges can be accessed via the [...] button.

Primary and Secondary Underlays
The primary and secondary underlays provide the 
opportunity to use two underlay types in conjunc-
tion. This also allows you to layer one underlay over 
another.
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Corners
Corners can be troublesome areas for embroidery. The problem arises as stitches nav-
igate around corners. It can be common for them to bunch up and cause puckering, 
thread breaks, and even holes in the garment. Notice the dark area of stitches in the 
example. Such tight stitching is problematic.

Changing how the stitches handle the tighter angled corners can smooth these prob-
lems out.

Single line column elements have a "Corners" property. This object properties sub-cate-
gory will allow you to choose how that element handles corners.

Cap
Capping the corners is a way to keep the stitches in a consistent 
direction and maintain an even stitch spacing. The drawback of cap-
ping comes from the limited range of use. Larger corners should not 
be capped as longer satin stitches are prone to snagging and becom-
ing loose. Try to avoid creating satin stitches longer than 60 points in 
length.

To cap a single line column corner, check the cap option check box 
in the "Corners" sub-category. If the angle of the corner falls within 
range, the corner will cap.

•	 Angle - This sets the threshold for when a corner is capped.

•	 Overlap - This sets the number of lines that the cap stitches 
will overlap the main leg of the column.

•	 Max St. Length - This determines the maximum stitch length allowed in the cap. Typically this limit 
will not be reached unless the "Use Fill for Stitches Greater Than..." feature has been disabled.

•• If an input point other than the exact corner or a stitch direction line other than bisecting the 
corner exists within the area to be capped, the capping feature will not cap the corner.

Example of how a capped corner sews
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Miter
Mitering corners is another way to keep the stitches in a more con-
sistent direction and maintain an even stitch spacing. Mitering works 
well for less extreme angles and wider satin stitches. It splits the cor-
ner in two pieces and overlaps at the bisection of the angle.

To miter a single line column corner, check the miter enable check 
box in the "Corners" sub-category. If the angle of the corner falls 
within range, the corner will miter.

•	 Type - This allows you to select the type of miter.

•	 Type 1 - This is what many people think of when they think of 
a mitered corner. It gives the appearance like the corner of a 
picture frame.

•	 Type 2 - This type of miter can mimic the more traditional cor-
ner from a traditional sewing machine. It does not taper the stitches. It gives a more squared-off 
appearance to the corner.

•	 Angle - This sets the threshold for when a corner is mitered.

•	 Overlap - This sets the amount the stitch lines are extended underneath the second half of the 
mitered corner.

•• If an input point other than the exact corner or a stitch direction line other than bisecting the 
corner exists within the area to be mitered, the mitering feature will not affect the corner.

Example of how a miter type 1 
corner sews

Example of a miter 
type 2
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View
The View category lists check boxes for visual components. Check the ones that you would like to see. 
Unchecked ones will be left hidden.

•	 Show Wireframe Points - This option displays the wireframe points even when the element is not 
selected. Selected elements typically display these points as slightly enlarged.

•	 Show Wireframe Lines - This option displays the wireframe outlines of elements even when the 
element is not selected.

•	 Show Stitches - This element shows the stitches of the element. This is the same function as the 
show/hide stitches button on the view toolbar.

•	 Show Expanded Points - This displays the expanded points of an element. It displays the needle 
penetrations as small plus signs. This is the same function as the toggle expanded points button 
on the view toolbar.
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(Fabric) Styles
The Styles category allows you to apply a set of properties to a proj-
ect, a selection, or the defaults of the software. This can be a quick 
way to alter a design for a given fabric or application.

Creating A Style
To create a style,

1.	 Access the Styles category in Object Properties.

2.	 Click the Create Style... button.

3.	 Name the style to be created and click OK.

4.	 Populate the object properties window that pops up with your desired properties.

5.	 Click OK.

6.	 The new style is now available in the drop-down menu.

Editing an Existing Style
To edit a style,

1.	 Access the Styles category in Object Properties.

2.	 Select the style to be edited from the style drop-down menu.

3.	 Click the Edit button.

4.	 Make the desire changes to the properties pop-up.

5.	 Click OK.

Deleting an Existing Style
To delete a style,

1.	 Access the Styles category in Object Properties.

2.	 Select the style to be edited from the style drop-down menu.

3.	 Click the Delete button.

Applying A Style
To apply a style,

1.	 Access the Styles category in Object Properties.

2.	 Select the style to be edited from the style drop-down menu.

3.	 Select to apply the style to the project, defaults, or selection from the drop-down.

4.	 Click Apply.



















137 of 218

Digitizing & Editing Icons & Cursors
As you move the cursor throughout the view window, it will change to indicate a multitude of positions 
or states. These are listed below.

Editing Cursors

Edit Mode

•	 You can select elements

Cursor Over an Element

•	 You can click and drag to move the element.

•	 Hold [Alt] to constrain the movement to the X or Y axis.

Cursor Over a Line

•	 You can add points along the line.

•	 Click and drag to move the line

Cursor Over a Straight Point

•	 Click and drag to move the point.

•	 Hold [Shift] and click on the point to change it to a Curve Point.

•	 Hold [Shift] and click and drag off of the point to create a bezier handle.

Cursor Over a Curve Point

•	 Click and drag to move the point.

•	 Hold [Shift] and click on the point to change it to a Straight Point.

Cursor Over an Entry or Exit Point (or using the Entry/Exit Tool)

•	 Click and drag to move the entry or exit point to a new location.

Cursor Over a Letter Handle

•	 Click and drag on the handle to move the letter.

•	 Hold [Ctrl] and click and drag to move the letter off the line.

Cursor Over a Spacing Handle

•	 Click and drag on the handle to alter the spacing or arc line.

Cursor Over a Bezier Handle

•	 Click and drag on the bezier handle to alter a curve.
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Stitch Directions and Curves

Watch your stitch directions on curves. Think of spokes on a wheel. Don’t try to “help” the curve along. 
Notice how poorly the stitches fan on the example.

"Pairs" of Points

The points within a pair don’t have to be of the same type. Notice on the middle pair that the top is a 
curve point, and the bottom is a straight.

Creating Complex Curves with Columns
When dealing with more complex curves, try to divide the curves into simpler ones. Avoid exceeding 
180° in any set of three pairs. Also, try to think about your stitch directions as spokes on a wheel. Each 
one should come out from the center of the arc.

Too Few Wireframe Points Too Many Wireframe PointsIdeal Number of Wireframe Points
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